Brute Networking

Building brute networks

Previous Entry Share Next Entry
Анонсирование Loopback
Router
brutenet
При анонсировании Loopback в протокол маршрутизации (проверял на OSPF) он, независимо от маски установленной на интерфейсе, анонсируется с маской /32.

То ли мы невнимательно читаем документацию, то ли что, но для всех нас это было неожиданностью.

------ R1
interface Loopback3
ip address 20.0.0.1 255.255.255.0
!
interface Ethernet0/0
no ip address
half-duplex
!
interface Ethernet0/0.20
encapsulation dot1Q 20
ip address 20.0.1.1 255.255.255.0
!
router ospf 1
network 20.0.0.0 0.0.0.255 area 31
network 20.0.1.0 0.0.0.255 area 31

R1# show version
IOS (tm) 3600 Software (C3640-JS-M), Version 12.3(24), RELEASE SOFTWARE (fc4)

------ R2
R2#sh ip rout
...
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O IA 20.0.1.0/24 [110/74] via 137.20.101.3, 00:00:00, Serial1/0.2
O IA 20.0.0.1/32 [110/65] via 137.20.101.3, 00:01:06, Serial1/0.2


  • 1
Сделай так:

interface Loopback3
ip ospf network point-to-point
ip address 20.0.0.1 255.255.255.0


По умолчанию у всех Loopback-интерфейсов тип сети "loopback" (можно увидеть по show ip ospf interface) и, соответственно, они анонсируются с маской /32 (потому как считается, что за ними все равно ничего нет и быть не может).

О, огромное спасибо за разъяснение!

Очень понравился ваш ЖЖ, я вас зафренжу и было бы круто если бы вы ответили взаимно;)

Добрый день, возможно вам будет интересно полезное сообщество-
kidalovo_Различные виды кидалова, мошенничества, обманы в нашей жизни. Реальные интересные случаи из жизни.... П.Р.И.С.О.Е.Д.И.Н.И.Т.Ь.С.Я.!

Вступайте, будем вам рады! Спасибо.
Извините за беспокойство:)

Krokodil

(Anonymous)
Почему то сильно мало у вас посетителей, для такого хорошего блога=(

Hoping to make a contribution

(Anonymous)
Hey - I am certainly happy to discover this. great job!

  • 1
?

Log in